lc16m, mode2 output but no irw

Linux support for Soundgraph iMON USB IR/VFD modules used in Ahanix, Silverstone, Uneed, Accent and other cases.

Moderator: Venky

Post Reply
Posts: 2
Joined: Mon Jul 31, 2006 3:00 am

lc16m, mode2 output but no irw

Post by erland » Mon Jul 31, 2006 3:20 am

I'm trying to get the IR to work on my Ubuntu box running in a LC16M case.

I have compiled 0.8.0 and installed it, the current status is:

When I run mode2 I get output like this when pressing the remote buttons:

Code: Select all

code: 0x28b595b7
code: 0x28b5d5b7
code: 0x2bb195b7
code: 0x2bb1d5b7
code: 0x28b195b7
code: 0x28b1d5b7
When I startup "lircd --device=/dev/lirc" I get the following output in syslog

Code: Select all

Jul 31 12:04:43 htpclin lircd: lircd(imon) ready
When I startup irw I get no output at all when pushing buttons on the remote.

I think the VFD is working correctly because this shows Hello on the VFD screen:
echo "Hello" >/dev/lcd0

When running modprobe on lirc_dev and lirc_imon dmesg contains the following:

Code: Select all

[17190323.356000] lirc_dev: IR Remote Control driver registered, at major 61
[17190328.796000] /usr/src/lirc-0.8.0/drivers/lirc_imon/lirc_imon.c: Driver for Soundgraph iMON MultiMedian IR/VFD, v0.3
[17190328.796000] /usr/src/lirc-0.8.0/drivers/lirc_imon/lirc_imon.c: Venky Raju <>
[17190328.796000] /usr/src/lirc-0.8.0/drivers/lirc_imon/lirc_imon.c: imon_probe: found IMON device
[17190328.796000] lirc_dev: lirc_register_plugin: sample_rate: 0
[17190328.796000] /usr/src/lirc-0.8.0/drivers/lirc_imon/lirc_imon.c: imon_probe: Registered iMON plugin (minor:0)
[17190328.796000] /usr/src/lirc-0.8.0/drivers/lirc_imon/lirc_imon.c: imon_probe: iMON device on usb<1:3> initialized
[17190328.796000] usbcore: registered new driver lirc_imon
I have tried to compile it with both "Soundgraph iMON Multimedian IR/VFD" and with "Soundgraph iMON PAD IR/VFD" but the behaviour seems to be the same.

Any help or ideas are appreciated

Posts: 2
Joined: Mon Jul 31, 2006 3:00 am

Post by erland » Mon Jul 31, 2006 7:02 am

Nevermind, I got it to work.

The problem was that I had the lircd.conf file for "Soundgraph iMON Multimedian IR/VFD" instead of "Soundgraph iMON PAD IR/VFD" in /etc/lircd.conf.

As soon as I put the PAD lircd.conf file irw works and gives the correct output.

Posts: 2
Joined: Fri Aug 25, 2006 4:46 am

thks to you

Post by Ezekiel78 » Fri Aug 25, 2006 4:49 am

irw work yet
and the good code are displayed
but i need a lircmd.conf file
do you have some ?
sorry for my poor english i am french : )

Post Reply