Silverstone LC10M owners...

Linux support for Soundgraph iMON USB IR/VFD modules used in Ahanix, Silverstone, Uneed, Accent and other cases.

Moderator: Venky

fromans4
Posts: 28
Joined: Fri Nov 25, 2005 6:49 pm
Location: Northern California
Contact:

Post by fromans4 » Fri Nov 25, 2005 6:55 pm

* What are vendor & device codes?
- In USBVIEW my Vendor ID is 15c2 & my Product ID is ffdc
* Is the current driver working for the VFD?
- Yes
* Is the current driver working for the IR?
- Yes
* Does your remote have a joystick?
- Yes but it is not working.

Brent

harald
Posts: 3
Joined: Sun Dec 11, 2005 10:46 am

Post by harald » Sun Dec 11, 2005 11:22 am

LC10M, same as ixalon, except that this hardware is ofcourse built into the LC10M.
idVendor: 0x15c2 - idProduct: 0xffdc
VFD working
IR not working
Remote has joystick (iMON PAD) as seen in http://www.soundgraph.com/pr/e_pr_11.asp?m1d=1&m2d=11

vondo

Not working here

Post by vondo » Thu Jan 05, 2006 6:20 am

# What are vendor & device codes?
# Is the current driver working for the VFD?
# Is the current driver working for the IR?
# Does your remote have a joystick?

15c2:ffdc
No
No
More of a joypad, right? Yes.

I just got the case, but cannot get things working.

I've built and installed lcdproc-0.4.5-imon.tgz and lirc-0.7.2 from the sources. I'm using the Imon-PAD driver. Is that the correct one?

I do modprobe lirc_imon and the modules are installed. lircd starts and doesn't complain, but when I run irw to try and see what's codes may come in, it dies immediately and I get these lines in the lirc log file:

Jan 5 08:17:28 localhost lircd 0.7.2: accepted new client on /dev/lircd
Jan 5 08:17:28 localhost lircd 0.7.2: could not get file information for /dev/lirc
Jan 5 08:17:28 localhost lircd 0.7.2: default_init(): No such file or directory
Jan 5 08:17:28 localhost lircd 0.7.2: caught signal

and lircd is now dead.

The LCD doesn't work yet either. If I start LCDd, I get lines like this in /var/log/messages:
Jan 5 07:55:33 localhost LCDd:
Jan 5 07:55:33 localhost LCDd: ^[[5d^[[9;29H
Jan 5 07:55:33 localhost LCDd: ^[[6d
Jan 5 07:55:33 localhost LCDd:
Jan 5 07:55:33 localhost LCDd: ^[[9;29H
Jan 5 07:55:33 localhost LCDd:
Jan 5 07:55:33 localhost LCDd: ^[[9;29H
Jan 5 07:55:33 localhost LCDd: ^[[14d
Jan 5 07:55:33 localhost LCDd:
Jan 5 07:55:33 localhost LCDd: ^[[17d^[[9;29H

Thanks for any help anyone can give or if I can answer other questions.

vondo

Power button

Post by vondo » Thu Jan 05, 2006 11:34 am

I forgot to ask a question.

Using the power (red) button on the remote, if I have everything hooked up correctly, should I be able to power up the PC with the remote? I mean, with no drivers or anything installed. Also, with no drivers installed should I see the VFD do anything or should it remain completely dark?

I don't know if I got my grounds and such crossed in hooking up the power button since my MB doesn't say which one is ground.

Thanks,

Eric

vondo

Solved

Post by vondo » Thu Jan 05, 2006 8:37 pm

After another evening of fiddling, I appear to have solved my problems:

1) Rewired the VFD to make sure I got ground and +5 right on the MB (don't know if that did anything since it was the first thing I did).

2) Mandrake had lirc stuff in their kernel package. I delete it all and then reinstalled lirc and lcdproc from the packages here

3) The instructions here say to put LCDd.conf in /etc, but the init scripts for RH-like systems look in /usr/local/etc

After that, everything is cool. Now I have to figure out how to put what *I* want on the VFD.

Thanks for the great drivers!

Guest

Post by Guest » Mon Feb 13, 2006 11:52 am

vendor: 0x15c2, product: 0xffdc
IR: seems to work (at least the driver and lirc), but since I do not have any application being abled to work with it, I could not test it yet
VFD: does not compile (see also viewtopic.php?t=129)
IR with joystick: a small one in the middleof the IR, yes

Guest

Post by Guest » Fri Mar 10, 2006 5:37 am

15c2:ffda

VFD working. IR stops working after a few seconds.

Kernel 2.6.15 SMP.
lirc 0.8.0

MFrandsen
Posts: 1
Joined: Wed Apr 12, 2006 11:03 pm

Post by MFrandsen » Wed Apr 12, 2006 11:10 pm

15c2:ffdc
VFD working only anoying is that it quit with the display powered.
IR working and with the default conf irw returned correct codes.
My remote have a joystick but not working since I just use the lirc 0.8.0 I guess without any patch.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests